{"_id":"5a035dc466792f0010a364c2","project":"555fbba928249c1900618a82","initVersion":{"_id":"59d693db6d3f930010332ec9","version":"2.8"},"user":{"_id":"559d8781454aef21005a5f6b","username":"","name":"Rachel Quick"},"__v":0,"hidden":true,"createdAt":"2017-11-08T19:40:52.917Z","fullscreen":false,"htmlmode":false,"html":"","body":"[block:callout]\n{\n  \"type\": \"danger\",\n  \"body\": \"IMPORTANT UPDATE FOR RECURLY CLIENT LIBRARIES RELEASED PRIOR TO MAY 9, 2018\"\n}\n[/block]\n##Issue Summary\nAs part of our ongoing security assessment, Recurly has become aware of a moderate potential security vulnerability for some use cases in our Python client.\n\nRecurly takes your security very seriously. Recurly has released patches for existing versions of the Python library to remediate potential vulnerabilities and recommends an immediate update.\n\n##Impacted Versions\n2.0.x should upgrade to 2.0.6\n2.1.x should upgrade to 2.1.17\n2.2.x should upgrade to 2.2.23\n2.3.x should upgrade to 2.3.2\n2.4.x should upgrade to 2.4.6\n2.5.x  should upgrade to 2.5.2\n2.6.x should upgrade to 2.6.3\n2.7.x should upgrade to 2.7.1\n2.8.x should upgrade to 2.8.2\n\n\n##Regenerating API keys\nAs an additional security recommendation, please revoke/regenerate your API keys.\n[Follow our documentation](https://docs.recurly.com/docs/api-keys#section-revoking-an-api-key) on Revoking an API Key\n\n##For Additional Support\nPlease [contact support](support.recurly.com) for assistance related to this patch.","slug":"python-updates","title":"Python Updates"}

Python Updates


[block:callout] { "type": "danger", "body": "IMPORTANT UPDATE FOR RECURLY CLIENT LIBRARIES RELEASED PRIOR TO MAY 9, 2018" } [/block] ##Issue Summary As part of our ongoing security assessment, Recurly has become aware of a moderate potential security vulnerability for some use cases in our Python client. Recurly takes your security very seriously. Recurly has released patches for existing versions of the Python library to remediate potential vulnerabilities and recommends an immediate update. ##Impacted Versions 2.0.x should upgrade to 2.0.6 2.1.x should upgrade to 2.1.17 2.2.x should upgrade to 2.2.23 2.3.x should upgrade to 2.3.2 2.4.x should upgrade to 2.4.6 2.5.x should upgrade to 2.5.2 2.6.x should upgrade to 2.6.3 2.7.x should upgrade to 2.7.1 2.8.x should upgrade to 2.8.2 ##Regenerating API keys As an additional security recommendation, please revoke/regenerate your API keys. [Follow our documentation](https://docs.recurly.com/docs/api-keys#section-revoking-an-api-key) on Revoking an API Key ##For Additional Support Please [contact support](support.recurly.com) for assistance related to this patch.